标签:四边形不等式优化,单调队列,二分,决策单调性DP
题目
Output 对于每组数据,若最小的不协调度不超过1018,则第一行一个数表示不协调度若最小的不协调度超过1018,则输出”Too hard to arrange”(不包含引号)。每个输出后面加”——————–” Sample Input 4
4 9 3
brysj,
hhrhl.
yqqlm,
gsycl.
4 9 2
brysj,
hhrhl.
yqqlm,
gsycl.
1 1005 6
poet
1 1004 6
poet
Sample Output 108
32
Too hard to arrange
1000000000000000000
【样例说明】
前两组输入数据中每行的实际长度均为6,后两组输入数据每行的实际长度均为4。一个排版方案中每行相邻两个句子之间的空格也算在这行的长度中(可参见样例中第二组数据)。每行末尾没有空格。
HINT
总共10个测试点,数据范围满足:
测试点 T N L P 1 ≤10 ≤18 ≤100 ≤5 2 ≤10 ≤2000 ≤60000 ≤10 3 ≤10 ≤2000 ≤60000 ≤10 4 ≤5 ≤100000 ≤200 ≤10 5 ≤5 ≤100000 ≤200 ≤10 6 ≤5 ≤100000 ≤3000000 2 7 ≤5 ≤100000 ≤3000000 2 8 ≤5 ≤100000 ≤3000000 ≤10 9 ≤5 ≤100000 ≤3000000 ≤10 10 ≤5 ≤100000 ≤3000000 ≤10 所有测试点中均满足句子长度不超过30。
分析
前置技能:四边形不等式优化
byvoid的题解好神啊,我也懒得写了https://www.byvoid.com/zhs/blog/noi-2009-poet
code
#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cmath>
#include<cstring>
#include<algorithm>
#define rep(i,a,b) for(int i=a;i<=b;i++)
#define dep(i,a,b) for(int i=a;i>=b;i--)
#define ll long double
#define mem(x,num) memset(x,num,sizeof x)
#define reg(x) for(int i=last[x];i;i=e[i].next)
#define inf 1000000000000000000LL
using namespace std;
inline ll read()
{
ll f=1,x=0;char ch=getchar();
while(ch<'0'||ch>'9'){if(ch=='-')f=-1;ch=getchar();}
while(ch>='0'&&ch<='9'){x=x*10+ch-'0';ch=getchar();}
return x*f;
}
const int maxn=1e5+6;
int T,n,l,p;
ll s[maxn],f[maxn],from[maxn];
char ch[maxn][36];
struct node{int l,r,p;}que[maxn];
ll pow(ll x){if(x<0)x=-x;ll re=1;rep(i,1,p)re*=x;return re;}
ll cal(int j,int i){return f[j]+pow(s[i]-s[j]+(i-j-1)-l);}
int find(node t,int x){//二分查找最优决策点
int l=t.l,r=t.r,mid;
while(l<=r){
mid=(l+r)>>1;
if(cal(t.p,mid)<cal(x,mid))l=mid+1;else r=mid-1;
}
return l;
}
void dp(){
int head=1,tail=0;que[++tail]=(node){0,n,0};
rep(i,1,n){
if(head<=tail&&i>que[head].r)head++;
f[i]=cal(que[head].p,i);from[i]=que[head].p;
if(head>tail||cal(i,n)<=cal(que[tail].p,n)){
while(head<=tail&&cal(i,que[tail].l)<=cal(que[tail].p,que[tail].l))tail--;
if(head>tail)que[++tail]=(node){i,n,i};
else{int t=find(que[tail],i);que[tail].r=t-1;que[++tail]=(node){t,n,i};}
}//单调队列优化
}
}
int main()
{
T=read();
while(T--){
n=read();l=read();p=read();
rep(i,1,n)scanf("%s",ch[i]);
rep(i,1,n)s[i]=s[i-1]+strlen(ch[i]);
dp();
if(f[n]>inf)puts("Too hard to arrange");else printf("%lld\n",(long long)f[n]);
puts("--------------------");
}
return 0;
}