Bzoj1072 [scoi2007]排列perm

阅读全文大概需要 2分钟
本文总阅读量
Posted by yjjr's blog on February 6, 2018

标签:状压DP

Description

  给一个数字串s和正整数d,统计s有多少种不同的排列能被d整除(可以有前导0)。例如12343490种排列能
2整除,其中末位为2的有30种,末位为4的有60种。

Input

  输入第一行是一个整数T,表示测试数据的个数,以下每行一组sd,中间用空格隔开。s保证只包含数字0, 1
, 2, 3, 4, 5, 6, 7, 8, 9.

Output

  每个数据仅一行,表示能被d整除的排列的个数。

Sample Input

7

000 1

001 1

1234567890 1

123434 2

1234 7

12345 17

12345678 29

Sample Output

1

3

3628800

90

3

6

1398

HINT

在前三个例子中,排列分别有1, 3, 3628800种,它们都是1的倍数。
【限制】
100%
的数据满足:s的长度不超过10,1<=d<=1000, 1<=T<=15

 

状压DP模板题,f[i][j]表示状态为i时余数为j的个数

然后排列组合去重

 

Code

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<algorithm>
#define rep(i,a,b) for(int i=a;i<=b;i++)
#define dep(i,a,b) for(int i=a;i>=b;i--)
#define LL long long
#define mem(x,num) memset(x,num,sizeof x)
using namespace std;
inline LL read()
{
	LL f=1,x=0;char ch=getchar();
	while(ch<'0'||ch>'9'){if(ch=='-')f=-1;ch=getchar();}
	while(ch>='0'&&ch<='9'){x=x*10+ch-'0';ch=getchar();}
	return x*f;
}
const int maxn=20;
LL bin[20],T,d,len,a[maxn],v[maxn],tot[maxn],f[1<<11][1<<11];
char ch[maxn];

void dp()
{
	rep(i,0,bin[len]-1)
	    rep(j,0,d-1)f[i][j]=0;
	f[0][0]=1;
	rep(i,0,bin[len]-1)
	    rep(j,0,d-1)
	        if(f[i][j])
				rep(x,1,len)
			        if((bin[x-1]&i)==0)
						f[i|bin[x-1]][(a[x]+j*10)%d]+=f[i][j];
}

int main()
{
	T=read();
	bin[0]=1;rep(i,1,19)bin[i]=bin[i-1]<<1;
	while(T--){
		scanf("%s",ch+1);d=read();
		len=strlen(ch+1);
		rep(i,0,9)v[i]=1,tot[i]=0;
		rep(i,1,len){
			a[i]=ch[i]-'0';
			tot[a[i]]++;
			v[a[i]]*=tot[a[i]];
		}
		dp();
		rep(i,0,9)f[bin[len]-1][0]/=v[i];
		printf("%lld\n",f[bin[len]-1][0]);
	}
	return 0;
}


本文可以转载,但必须附上原文链接,否则你会终生找不到妹子!!!欢迎关注我的CSDN: ahyjjr